Module:Effective protection expiry/doc

From Wikipedia, the free encyclopedia
Jump to navigation Jump to search

This module provides a way to retrieve the expiry of a restriction over a given action on a page.

Usage[edit]

This module will use up to 1 expensive parser function call each time it is ran. It will not use any if Module:Effective protection level was already called.

From other modules[edit]

To load this module:

local effectiveProtectionExpiry = require('Module:Effective protection expiry')._main

The function accepts two parameters. The first is a string containing the action to check, which must be one of "edit", "create", "move", "upload", or "autoreview". The second is optional, and can either be the name of the page to check, or a title returned from the mw.title functions. If the second parameter is omitted, the page being displayed is the one checked against.

The return value is either a date string in YY-MM-DDThh:mm:ss format, or one of the following strings:

  • infinity - for pages protected indefinitely, or pages which exist and are not protected
  • unknown - for pages where the expiry is unknown, or pages which do not exist and are not protected

Note that if an existing page is not protected for the requested action, this will return 'infinity'. You need to check separately with Module:Effective protection level.

From wikitext[edit]

The parameters are the same as when it is called directly.

{{#invoke:Effective protection expiry|action|title}}

See also[edit]